• #1 by DanM on 17 Jan 2023
  • I am running MFP 8 on a Windows Server (Windows Server 2022 Standard). I keep getting the attached error message after the login screen.

    Cannot create file C:\users\ADMINI~1\Appdata\Local\Temp\2\SUIPAKT.sui

    If I unsinstall it and then do a fresh install it loads fine for the first time I run it but if I close it down and then try to run it and login again I get the same error message.
  • #2 by Tim (WellDoneSoft) on 17 Jan 2023
  • Oh, I see.
    We use a third party component that places this file to temp dir when app starts.
    Looks like either something cleans this dir either prevents creating/placing files to the temp.
    One more thing: when you install the app you probably run it right at the end of the installation process.
    At this point you act under Administrator account. So MarketFeeder creates that file in temp folder as Administrator.
    Then when you close the app and run it from Start menu you act as user and probably this user doesn't have rights to read this file.
    So try uninstall, re-install the app and not run it from the installation process (untick and finish). And then run from Start.

    Let me know if nothing helps.
  • #3 by DanM on 20 Jan 2023
  • Thanks for the reply. It runs fine from the start menu. And it also runs fine if I reboot the server as an alternative to reinstalling.

    However, I have made sure there are no other applications running at all and I only ever login as Administrator but I still get the error.
  • #4 by Tim (WellDoneSoft) on 20 Jan 2023
  • Could you please do it again:
    1. Stop all copies of MF.
    2. Uninstall it.
    3. Delete folders if they are:
    - c:\Program Files\MarketFeeder Pro 8\
    - c:\Program Files (x86)\MarketFeeder Pro 8\
    - c:\Users\Administrator\AppData\Local\Temp\2\
    4. Download the latest version
    5. Install it and don't run at the end.
    6. Start from Start menu.

    Thank you.
  • #5 by DanM on 25 Jan 2023
  • Thanks - tried all that step by step but still getting the error.

    Also when I leave the app running (so I don't have to reboot or reinstall) I get an Abnormal Termination message and the app has closed. 
  • #6 by DanM on 28 Jan 2023
  • So this time the application did not abnormally close but I was unable to use Market Locator -


    Exception EreadError in module mlocator.dll at 0010E313

    when I tried - screenshot attached.

    I was able to manually add markets but decided to close and re-open but then got the original error in my original post.

    Rebooted server and now all works fine (until tomorrow I guess).
  • #7 by Oxa (WellDoneSoft) on 02 Feb 2023
  • Hello!

    The error messages look like they are triggered by the lack of permissions for MarketFeeder Pro to read or write files on your disk.
    I can see that you are logged in as Administrator though.

    Can you please attach your program log for the days on which you were getting the errors?

    You can find out how to view the program log in this video:

    Also, how many markets do you normally refresh at the same time?
  • #8 by DanM on 02 Feb 2023
  • Logs attached.

    I only look at Uk and Irish horse racing win markets so in terms of markets being refreshed say betwwen 21 and 40 ish