Author Topic: Trigger not activating after scheduled market refreshes  (Read 428 times)

Tags:
  • All members
  • Posts: 4
  • Karma: +0/-0
  • Gender: Male
Trigger not activating after scheduled market refreshes
« on: Mon, 01 January, 2018, 06:23 »
Hi, I’m having trouble with activating triggers after auto-market monitoring refreshes and re-loads

At present, I have the software set to refresh the markets every 6 hours.

This function works, but the trigger does not activate correctly.

Markets are processed but no bets are laid even though all conditions are met

I can resolve the issue at present by manually re-loading the trigger. But no good if I'm not around to do it.

Is there anything I might have missed? I could not find this specific issue addressed elsewhere.

many thanks

Scott

  • All members
  • Posts: 801
  • Karma: +39/-1
Re: Trigger not activating after scheduled market refreshes
« Reply #1 on: Mon, 01 January, 2018, 08:25 »
Do you overwrite or delete existing markets?
If using a staking plan, are you retaining the previous few settled markets?

  • All members
  • Posts: 4
  • Karma: +0/-0
  • Gender: Male
Re: Trigger not activating after scheduled market refreshes
« Reply #2 on: Mon, 01 January, 2018, 08:44 »
Hi Rubold, 

I have ticked the box which asks whether you want to "clear existing markets first".

I am using "simple lay staking plan"

When the markets are refreshed, and the window is populated again with new markets - no entries are retained from previous sessions

Thank you for your help!

Scott

  • All members
  • Posts: 801
  • Karma: +39/-1
Re: Trigger not activating after scheduled market refreshes
« Reply #3 on: Mon, 01 January, 2018, 09:18 »
Hi Rubold, I have ticked the box which asks whether you want to "clear existing markets first". I am using "simple lay staking plan" When the markets are refreshed, and the window is populated again with new markets - no entries are retained from previous sessions Thank you for your help! Scott

That is your problem then.  Don't tick the box to clear existing markets first as the betting trigger will not know the outcome of the Previous triggered event, since it will be deleted.  If you want to reduce the number of markets listed under My Markets then go to Settings-General Options-Market Settings and tick Delete Finished events automatically and tick Delete all except 6 most recent markets.

  • All members
  • Posts: 4
  • Karma: +0/-0
  • Gender: Male
Re: Trigger not activating after scheduled market refreshes
« Reply #4 on: Mon, 01 January, 2018, 10:03 »
Thank you Rubold, I will give that a try. Also, is it mandatory to delete all except the 6 most recent markets? Can I set that figure to any other amount? Say, 20?

  • All members
  • Posts: 801
  • Karma: +39/-1
Re: Trigger not activating after scheduled market refreshes
« Reply #5 on: Mon, 01 January, 2018, 10:08 »
Yes you can set any figure above 2, I was just giving that as a suggestion.

  • All members
  • Posts: 4
  • Karma: +0/-0
  • Gender: Male
Re: Trigger not activating after scheduled market refreshes
« Reply #6 on: Mon, 01 January, 2018, 22:21 »
Many thanks Rubold, that fixed it. Cheers Scott