Author Topic: access violation, when variable screen opened  (Read 4106 times)

Tags:
  • Moderator
  • Posts: 4122
  • Karma: +242/-9
  • Gender: Male
*
access violation, when variable screen opened
« on: Thu, 05 January, 2012, 18:18 »
hi
i am getting an access violation message after the bot has run for about half an hour.
i have downloaded a new bot and installed in a different drive but the same happens.
i have given full access through the firewall and antivirus.
all seems ok until i check my variables, then error.


mcbee
Please read the following  disclaimer with regards to the information you may request and obtain on our forum. This specifically concerns trigger files and various instructions as to how to implement a strategy.

  • Tim Vetrov
  • Administrator
  • Posts: 3900
  • Karma: +151/-0
  • Gender: Male
*
Re: access violation, when variable screen opened
« Reply #1 on: Fri, 06 January, 2012, 09:19 »
It looks like you have a "dead lock" in your triggers when you use a user variable before initializing its value and your computer run out of resources parsing the formula.
Could you please check your triggers or send the file to support.
I'm happy to help Monday - Friday, 08:00-18:00 GMT
Буду раз помочь с понедельника по пятницу, 08:00-18:00 GMT

  • Moderator
  • Posts: 4122
  • Karma: +242/-9
  • Gender: Male
*
Re: access violation, when variable screen opened
« Reply #2 on: Fri, 06 January, 2012, 10:59 »
hi tim
many thanks for the reply.
i am renaming my variables in 1 bot to see if it makes a difference.
and i will look to see if i can work out the dead lock
i have included my bank1 set of triggers (the selection is different)
maybe you can see the error

thanks
mcbee

trigger removed
Please read the following  disclaimer with regards to the information you may request and obtain on our forum. This specifically concerns trigger files and various instructions as to how to implement a strategy.

  • Tim Vetrov
  • Administrator
  • Posts: 3900
  • Karma: +151/-0
  • Gender: Male
*
Re: access violation, when variable screen opened
« Reply #3 on: Fri, 06 January, 2012, 12:47 »
See nothing wrong there. And no error messages yet (I settle markets manually). Is it a part of something big?
I'm happy to help Monday - Friday, 08:00-18:00 GMT
Буду раз помочь с понедельника по пятницу, 08:00-18:00 GMT

  • Moderator
  • Posts: 4122
  • Karma: +242/-9
  • Gender: Male
*
Re: access violation, when variable screen opened
« Reply #4 on: Fri, 06 January, 2012, 13:07 »
hi
yes, but they are all the same sets with different numbers pl1,pl2 etc.
with this one i had no errors today.
but i got this error for the first time on another testing ( same triggers ).

mcbee
Please read the following  disclaimer with regards to the information you may request and obtain on our forum. This specifically concerns trigger files and various instructions as to how to implement a strategy.

  • Moderator
  • Posts: 4122
  • Karma: +242/-9
  • Gender: Male
*
Re: access violation, when variable screen opened
« Reply #5 on: Fri, 06 January, 2012, 18:28 »
hi tim
i have added triggers to 0 any variable that has been used to update the seperate banks so that they all have a value of some sort, but i am still get access violation.
i will keep altering the variables to see where the problem is.
could it be that i am running the bot on a laptop.


mcbee
Please read the following  disclaimer with regards to the information you may request and obtain on our forum. This specifically concerns trigger files and various instructions as to how to implement a strategy.

  • Tim Vetrov
  • Administrator
  • Posts: 3900
  • Karma: +151/-0
  • Gender: Male
*
Re: access violation, when variable screen opened
« Reply #6 on: Fri, 06 January, 2012, 20:03 »
Adding 0 do nothing due to the parsing nature.
It becomes 0pl1 and still can't bet parsed.
But usually it just slows down the application wit no access violation error.
So it doesn't happen with other triggers file?
If so can I have the whole file to my e-mail please (NDA, etc.)
Thank you.
I'm happy to help Monday - Friday, 08:00-18:00 GMT
Буду раз помочь с понедельника по пятницу, 08:00-18:00 GMT

  • Moderator
  • Posts: 4122
  • Karma: +242/-9
  • Gender: Male
*
Re: access violation, when variable screen opened
« Reply #7 on: Fri, 06 January, 2012, 20:18 »
hi tim
many thanks for the help.
i think that i have located the problem, upto now 11 meetings and no error.
i have included an IF formula to make sure that the bet amount does not go below .01 and it seems to have fixed the problem.
why the bot would give multiple error's when the bet amount is below .01 i do not know.

hopefully fixed (will let you know on sat eve)

thanks again

mcbee

quick update
14 markets and 5 banks reached there profit, NO error.
Please read the following  disclaimer with regards to the information you may request and obtain on our forum. This specifically concerns trigger files and various instructions as to how to implement a strategy.

  • Moderator
  • Posts: 4122
  • Karma: +242/-9
  • Gender: Male
*
Re: access violation, when variable screen opened
« Reply #8 on: Fri, 06 January, 2012, 21:47 »
hi tim
the parsing bit that you were on about.
it could have been
bet trigger activated but no bet placed due to less than .01
other triggers were activated using the bet trigger and the selection affected by the bet trigger.
BUT, with no bet placed there was no index/selection or bm_backa or bm_backp
so the variables that was set to these figures had nothing to go on, thus the bot must have been looking for something that was not there.
a simple answer is.
when using the   any selection affected by    condition, also use and selections back/lay matched is greater than 0


thanks again for the help tim

mcbee
Please read the following  disclaimer with regards to the information you may request and obtain on our forum. This specifically concerns trigger files and various instructions as to how to implement a strategy.

  • Moderator
  • Posts: 4122
  • Karma: +242/-9
  • Gender: Male
*
Re: access violation, when variable screen opened
« Reply #9 on: Mon, 09 January, 2012, 08:50 »
hi
sat, i had a lot of time no electric, but no problems
sun, bots on all day and no errors.


mcbee
Please read the following  disclaimer with regards to the information you may request and obtain on our forum. This specifically concerns trigger files and various instructions as to how to implement a strategy.