Author Topic: Logs are not working properly  (Read 1892 times)

  • All members
  • Posts: 19
  • Karma: +1/-0
Logs are not working properly
« on: Sun, 27 January, 2013, 05:30 »
Hi Guys,

I'm having a number of problems with viewing the logs.

1) The account statement is not showing today's transactions.
     * Program Logs -> Account Statement  then click on the date. Today is not listed.
     * In the Program log I can see bets have been placed (confirmed in my bf account)
     * In the Program log i also see the market results entry
     * i'm betting on au races to win

2) In test mode, betting on au races for a place the races are never being closed after settlement.
     * when betting on au races for a win, its a lottery if the races are closed after settlement.
     * In live mode (test mode off), the win market is closing properly after settlement
     * In the Program log i can see the market results entry
   * i don't change anything between live/ test mode other than the mode change.


  • Moderator
  • Posts: 2788
  • Karma: +229/-0
*
Re: Logs are not working properly
« Reply #1 on: Sun, 27 January, 2013, 14:04 »
Hi
Check settings General Options > Account Statement
Either retrieve records from a given date, or not older than 0 days

Check settings > Test Mode
Either use download results from betfair, or simulated settlement (not both)  
Please read the following disclaimer with regards to the information you may request and obtain on our forum. This specifically concerns trigger files and various instructions as to how to implement a strategy.

  • All members
  • Posts: 19
  • Karma: +1/-0
Re: Logs are not working properly
« Reply #2 on: Mon, 28 January, 2013, 05:51 »
Great, thanks for the help. Point 1 sorted.

Point 2, i.e. closing the race after settlement is still not working?

Check settings > Test Mode
Under Event Results I have ticked both:
Download resuls from Betfair wherever possible and settle markets automatically
Finish a market automatically after settlement

Also on General Options i have ticked
Delete settled events automatically

is that correct?
I don't have anything ticked under Bet Settlement Simulator heading on the Test Mode page.

If however I do reverse the selection i.e. automatic settlement then my entries are cleared (but I don't get true results because of the random nature of selecting the winner)


  • Moderator
  • Posts: 2788
  • Karma: +229/-0
*
Re: Logs are not working properly
« Reply #3 on: Mon, 28 January, 2013, 08:23 »
Hi
Your settings are correct. Also check General Options > Account Statement > Retrieve bet list for AUS/NZ is checked, and Account Statement > AUS wallet is checked.

The results service and subsequent settlement in MarketFeeder in provided through rss.betfair.com
However, a quick check of betfair.com.au faq page reveals the following:
"Do you have a results service?
 
We do offer a results service. The Betfair Results Service delivers the results of non-Australian markets settled in the past 24 hours. Results are generated from the market settlement carried out 24/7 by our Market Operations team. Results are usually available within a matter of minutes of Betfair settling a market. This site can be viewed by going to rss.betfair.com.

Results of Australian horse racing can be accessed via our online Racing & results page at http://racingform.betfair.com.au/."

This topic is related and might be of some help:
http://community.welldonesoft.com/troubleshooting-8/australian-markets-in-test-mode/
Please read the following disclaimer with regards to the information you may request and obtain on our forum. This specifically concerns trigger files and various instructions as to how to implement a strategy.