Author Topic: Trigger green bulb no effect  (Read 3530 times)

Tags:
  • All members
  • Posts: 6
  • Karma: +1/-0
Trigger green bulb no effect
« on: Thu, 10 April, 2014, 19:55 »
Installed latest version 7.1.0.11. No triggers work, even the simplest. The main green bulb is on and also the one next to 'auto greenup' within the market itself. Nothing fires. Also, if hover mouse over market green bulb, the message is 'Turn triggers on for this market' i.e. the same as it is when the bulb is red. In the program logs, the trigger logs page is blank, so cannot see what is happening. Running the program as administrator. Ensured anti-virus is not blocking program. Tried test mode and real money one. Basically, no trigger works, even one as basic as back fav @ default back amount with no conditions. Market is being refreshed.

I have scoured the forum but cannot see any solutions. Can anybody help please? Many thanks

  • All members
  • Posts: 286
  • Karma: +25/-1
  • Gender: Male
Re: Trigger green bulb no effect
« Reply #1 on: Thu, 10 April, 2014, 21:12 »
Are all the constituent parts of your triggers "enabled" ?  Try opening the trigger editor and ensure that all appropriate ticks are in the boxes. If not this, uninstall and reinstall MFP and try it again. I'm not one of the Geeks so you'll probably get a more technical reply when they turn up.

  • Moderator
  • Posts: 2809
  • Karma: +231/-0
*
Re: Trigger green bulb no effect
« Reply #2 on: Thu, 10 April, 2014, 21:32 »
Hi
Further to what you have already tried and nigelbleddfa1 suggests:
In test mode please can you confirm you can place bets manually using the ladder or one-click on the market screen.

If you can do the above OK, please check:
  • you have test or real funds available
  • you are not betting from a Betfair restricted country
  • you are not betting below the Betfair minimum
  • Settings > General Options > Request confirmation for every critical operation is unticked
  • Settings > General options > By default all selections are active for auto-trading is ticked
  • Settings > Betting Options > Banking > nothing is ticked
  • Settings > Betting Options > Triggers > No triggering.... is unticked


If you have confirmed the above and still no triggers work, please create a new profile using the default settings and try again. (See manual section: Login Window)

Please post an update on your progress and we will take it further if needed.

Please read the following disclaimer with regards to the information you may request and obtain on our forum. This specifically concerns trigger files and various instructions as to how to implement a strategy.

  • All members
  • Posts: 6
  • Karma: +1/-0
Re: Trigger green bulb no effect
« Reply #3 on: Fri, 11 April, 2014, 08:25 »
Hi

Many thanks for your two swift replies. Yes, I have checked all the items you have both referred to, but with no success.

I have been using version 6 for years and so am very familiar with how that program works. To be honest, I still find it easier to use. I have previously tried using version 7, but could never get it to link with Excel successfully. Back last August Les Benning did offer to send me an analysis version of the software to find out what the problem was, and although I asked him to do so, I never heard back again. So, I have put off having another go at getting to grips with version 7 until this week, when I have had some time available.

After much experimentation and searching the forum, yesterday I finally got the link with Excel working correctly and I thought I had resolved everything, only to find this problem with the green bulbs not actually switching on the triggers, even though they are shown as 'active' when I right click on an event in 'my markets'. I have uninstalled and re-installed the program before I got the Excel part working. I have not tried creating a new profile though. I will give that a go and report back

Again, thanks for helping

  • All members
  • Posts: 6
  • Karma: +1/-0
Re: Trigger green bulb no effect
« Reply #4 on: Fri, 11 April, 2014, 08:56 »
Hi again Mark

I have re-installed the program then set up a new profile using the default settings. All the necessary boxes are unticked in settings that would prevent a trigger firing. The one click bet placing, using test funds and either the ladder or market screen, works. However, still a trigger does not.

When I hover over the green bulb next to 'Triggers' at the top of the screen it shows 'Triggers are active'. So that seems fine. However, when I hover over the other green bulb, next to 'Auto GreenUp is OFF' on the market screen it shows 'Turn triggers on for this market'. Again, if I turn the bulb to red the same  message appears. Thus it seems turning it 'on' to green has no effect. I am really at a loss to understand why! Any further help you can offer will be gratefully received!

  • Moderator
  • Posts: 4114
  • Karma: +241/-9
  • Gender: Male
*
Re: Trigger green bulb no effect
« Reply #5 on: Fri, 11 April, 2014, 10:54 »
hi  roadrunner and wellcome
please can you include the trigger that you are using and a screenshot of your betting options.
you may have to post one more before you can use the attach option due to people joining the forum and posting bad adverts on there first post.

mcbee
Please read the following  disclaimer with regards to the information you may request and obtain on our forum. This specifically concerns trigger files and various instructions as to how to implement a strategy.

  • Moderator
  • Posts: 2809
  • Karma: +231/-0
*
Re: Trigger green bulb no effect
« Reply #6 on: Fri, 11 April, 2014, 11:10 »
Hi
Thanks for following the checks mentioned above. I think the program is working OK because you can manually place bets. So the problem is with the triggering.

It is good that you are familiar with the program. You have probably tried this, but please check once more. The attached screenshot is taken from the manual and I have highlighted the main bits:
1. click the triggers link
2. click open triggers button and select the attached test trigger file
3. load some markets into my markets and ensure at least one is refreshing
4. turn triggers on (both bulbs must be green)
the trigger should fire immediately - it writes the text "this trigger fired" to the program log.

attached please find mentioned screenshot and test trigger file.

If it still does not work I can offer a TeamViewer remote support session to check your setup. Please PM me if you want to go ahead with this.
Please read the following disclaimer with regards to the information you may request and obtain on our forum. This specifically concerns trigger files and various instructions as to how to implement a strategy.

  • All members
  • Posts: 6
  • Karma: +1/-0
Re: Trigger green bulb no effect
« Reply #7 on: Fri, 11 April, 2014, 11:33 »
Hi McBee and Mark

Thank you for the welcome and offering to help. I tried to submit the screenshots you asked for, but the message seems to have failed twice. I will try and send again.

In the meantime, thanks Mark for your further advice. I will let you know if this solves it

I have been using Marketfeeder for many years - since version 4 I think, but this has got me stumped. Certainly I thought and do still think version 6 is better than the best thing since sliced bread! My difficulty now is that for using a new strategy I need to automatically load some markets which are non-standard in version 6, such as Half Time/Full Time. To do this manually is time consuming and tedious, whereas version 7 seems to allow you filter all markets and automatically select the ones you require

I am grateful for the assistance of you both and hope between us to get to the solution!

  • All members
  • Posts: 6
  • Karma: +1/-0
Re: Trigger green bulb no effect
« Reply #8 on: Fri, 11 April, 2014, 17:08 »
Hi all

Firstly, many thanks nigelbleddfa1, mcbee and MarkV for helping me out so promptly with this problem. I did try and send screenshots to mcbee as requested, but could not find a way to get the file sizes small enough to get below the attachment limit and they failed to send each time

No matter, as with your combined help I seem to have solved the difficulty and, as is often the case, it was due to a small detail. MarkV, the screen shot and test trigger were great. I had not worked out that you can keep the Active Trigger window open and on top. I knew how to open it up at the bottom of the screen on version 6. Anyway, with this open I could see the trigger command line flash green to show the trigger was executing and the log file confirmed it had worked. I then tried changing the setting to repeat not just once, but a set number of times and it worked each time. However, it was when I changed repeat to 'no more often than' that it did not work. Now, with the old version of the program when you used that command you could leave the secs as 0.00. Clearly, that is not the case in version 7 and was the key to my problem. I changed that to 2 secs and the trigger fired. I changed the trigger contents to something else to place a test back bet and it worked, so that was the root cause. Nevertheless, rather confusingly, when I hover the mouse over the green bulb in the market screen it still shows the message 'Turn triggers on for this market', the same as it does when the bulb is red. But in the end, the trigger was indeed active, as suggested by the green bulb symbol, but it was not having a time period in the repeat line was where it failed.

By the way, I mentioned that I could not get the latest software to successfully connect to Excel so that I could read data from the spreadsheet within the triggers I have devised. In case others have experienced similar difficulties, it may be worth mentioning that I finally solved that problem by: 1. Turning off Windows Defender; 2. Turning off Windows Firewall; and 3. Altering the settings within the firewall of my anti-virus software to allow inbound and outbound connections both for Marketfeeder and Excel.

Anyway, thanks to all again. With backup and support like this as well as the scope and flexibility that the software offers, it just confirms to me that Marketfeeder really is the best betting bot on the market!  :)

  • Moderator
  • Posts: 2809
  • Karma: +231/-0
*
Re: Trigger green bulb no effect
« Reply #9 on: Fri, 11 April, 2014, 18:57 »
Hi
Glad you got it sorted.
Please read the following disclaimer with regards to the information you may request and obtain on our forum. This specifically concerns trigger files and various instructions as to how to implement a strategy.